xref: /aosp_15_r20/external/clang/test/CXX/temp/temp.spec/temp.inst/p11.cpp (revision 67e74705e28f6214e480b399dd47ea732279e315)
1 // RUN: %clang_cc1 -verify -emit-llvm-only %s
2 
3 // rdar://problem/7838962
4 namespace test0 {
f0()5   template<typename T> unsigned f0() {
6     return T::MaxSize; // expected-error {{'int' cannot be used prior to '::'}}
7   };
8   template<typename T> struct A {
Allocatetest0::A9     void Allocate(unsigned Alignment
10                     = f0<T>()) // expected-note {{in instantiation}}
11     {}
12   };
f1(A<int> x)13   void f1(A<int> x) { x.Allocate(); }
14 
15 }
16